config/homes/desktop/xorg.nix
2024-09-29 16:42:01 +01:00

22 lines
390 B
Nix

{ config, ... }:
{
# Attempt to set keyboard layout
home.keyboard = {
layout = "gb";
options = [
"caps:escape"
];
};
# Force use of XDG Dir Spec
home.sessionVariables = {
XCOMPOSECACHE = "${config.xdg.cacheHome}/x11/xcompose";
};
# Set global font
xresources.properties = {
"*.font" = "Iosevka:pixelsize=12:antialias=true:autohint=true";
};
}