NixFiles/systems/nixos/users.nix

12 lines
294 B
Nix

{ config, pkgs, username, ... }:
{
users.users.${username} = {
isNormalUser = true;
shell = pkgs.zsh;
description = "Madeleine";
extraGroups = [ "adbusers" "dialout" "libvirtd" "plugdev" ];
openssh.authorizedKeys.keyFiles = [ ../../maddie/common/ssh/maddie.pub ];
};
}