NixFiles/systems/nixos/nix.nix

17 lines
316 B
Nix

{ config, pkgs, ... }:
{
# Enable flakes and nix-command
nix = {
package = pkgs.nixVersions.stable;
settings = {
experimental-features = [ "nix-command" "flakes" ];
auto-optimise-store = true;
};
gc = {
automatic = true;
options = "--delete-older-than 7d";
};
};
}