NixFiles/systems/macos/dock.nix

55 lines
1.7 KiB
Nix
Raw Permalink Blame History

This file contains invisible Unicode characters

This file contains invisible Unicode characters that are indistinguishable to humans but may be processed differently by a computer. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{ config, pkgs, username, ... }:
{
system.defaults = {
dock = {
# Don't show recent applications
show-recents = false;
# Set the dock size
tilesize = 55;
# Bottom right hot corner - Quick Nnote
wvous-br-corner = 14;
# Disable these hot corners
wvous-bl-corner = 1;
wvous-tl-corner = 1;
wvous-tr-corner = 1;
};
};
# Set the applications and folders on the dock
local.dock.entries = [
# Applications
{ path = "/System/Applications/Launchpad.app/"; }
{ path = "/Applications/Things3.app/"; }
{ path = "/Applications/RustRover.app/"; }
{ path = "/Applications/PyCharm.app/"; }
{ path = "/Applications/Emacs.app/"; }
{ path = "/Applications/iTerm.app/"; }
{ path = "/Applications/Obsidian.app/"; }
{ path = "/Applications/Tower.app/"; }
{ path = "/Applications/Sketch.app/"; }
{ path = "/System/Volumes/Preboot/Cryptexes/App/System/Applications/Safari.app"; }
{ path = "/System/Applications/Calendar.app/"; }
{ path = "/System/Applications/Notes.app/"; }
{ path = "/System/Applications/Freeform.app/"; }
{ path = "/System/Applications/FindMy.app/"; }
{ path = "/System/Applications/Music.app/"; }
{ path = "/System/Applications/Mail.app/"; }
{ path = "/System/Applications/Messages.app/"; }
{ path = "/System/Applications/FaceTime.app/"; }
{ path = "/Applications/Element.app/"; }
# Folders
{
path = "/Users/${username}/Documents/";
section = "others";
options = "--sort name --display folder";
}
{
path = "/Users/${username}/Downloads/";
section = "others";
options = "--sort dateadded";
}
];
}